30-12-2014 tarihinde eklendi
Düşeyara işlevi ile Excelde arama
Excelde arama Düşeyara işlevi ve kullanımı

Düşeyara fonksiyonu ile Excelde arama

Excel bizler için birçok tablo hesaplamasını yapabilecek alt yapıya sahip bir programdır. İçerisinde hücreler, satırlar sütunlar işlevler, biçimlendirmeler gibi birçok yapısal değişken ile işlemlerimizi kolaylaştırır. Excel içerisinde hazırladığımız bir tabloda bulmak istediğimiz bir değeri giriş sekmesindeki bul seçeneği ile ya da klavyeden CTRL + F klavye kısa yolları ile bulabiliyorduk. Fakat eğer aradığımız değeri değil de, onun diğer bilgilerini arıyorsak? Biraz karmaşık olduysa şöyle anlatalım. Örneğin bir firma sahibiyiz ve Excel’de çalışanlarımız ve aldıkları maaşları listeledik.

SORUN: Niyazi isimli çalışanımızın ne kadar maaş aldığını bulmak istiyoruz.

Normalde şuandaki listemiz biraz kısa olduğu için parmağımızla bile arayıp bulabiliriz. Fakat yüzlerce kişinin olduğu bir listede aradığımız kişiyi nasıl bulacağız? Yukarda da bahsettiğimiz gibi giriş sekmesindeki bul komutuyla(CTRL+F) bulabiliriz. Fakat bu seçenek ile sadece ismi aratabilir ve buldurabiliriz. Sonra da maaşına yan sütundan kendimiz bakarız. Yine biraz uzun bir işlem gibi duruyor değil mi? Hatta bulduğumuz bu maaşı bir hücre içerisine yazdırmak istersek işlem daha da karışır.

Bu gibi işlemleri rahatça halledebilmemiz için Excel’de Düşeyara işlevi bulunmaktadır. Düşeyara işlevi ile tabloda aradığımız bir veriyi bulabilir, bu veri ile ilgili işlemler yaptırabiliriz.

Düşeyara yapısal olarak =DÜŞEYARA(Aranan değer;tablo dizisi; Sütun indis sayısı;[aralık bak]) şeklindedir. Aranan değer tablo içerisinde arayacağımız değeri ifade eder. Bu düz bir metin ya da bir hücre olabilir. Biz bir adı tablo içerisinde bulmak istiyorsak bu alana direk tırnak işaretleri arasında da (“isim”) şeklinde yazabiliriz veya bu ismi bir hücreye yazıp o hücreyi tablo içerisinde de arayabiliriz. Sık kullanılan biçim ikinci yoldur. Tablo dizisi ise tablomuzun genişliğini ifade eden alandır. İşleve nerede arama yapması gerektiğini gösterir. Yukarıdaki tablo için A2:C14 yazmalıyız. Şu anda ismi belirli bir alanda aratmış olduk. İsim bulunduysa bu ismin kaçıncı sütunundaki verisini istediğimizi belirtmemiz lazım. Yukarıdaki tabloda C sütunu tablomuzda 3. Sütun olduğu için buraya 3 yazmamız gerekiyor. Aralık bak seçeneği ise bize net veya yaklaşık bir değer isteyip istemediğimizi sorar. Eğer buraya yanlış yazarsak veya 0(sıfır) yazarsak bize bulunan kesin sayıyı verir. Eğer kesin bir sayı yoksa #YOK yazar. Fakat buraya doğru yazarsak, 1 yazarsak veya boş bırakırsak bize eğer kesin bir sayı varsa kesin sayıyı yoksa yaklaşık sayıyı yazar.

İşlevimizin bölümlerinin açıklamalarını öğrendiğimize göre, şimdi yukarıdaki soruya dönelim ve Niyazi isimli çalışanımızı aratalım. Bunu yapmak için yazmamız gereken ifade

=DÜŞEYARA(“Niyazi”;A2:c14;3;0) olmalıdır. Şu durumda Excel’e A2 ve C14 hücreleri arasında “Niyazi” isimli kişinin 3 sütunundaki veriyi kesin olarak görüntüle demiş olduk.

Bize Niyazi isimli kişi bulundu ve 3 sütunundaki veri görüntülendi.

Eğer bunun gibi aratma işlemlerini sık sık yapıyorsak DÜŞEYARA alanına bir isim yazarak değil de, bir hücre belirterek yazmamız bizim açımızdan daha uygun olur. Yani =DÜŞEYARA(D2;A2:c14;3;0) yazarsak d2 hücresinde ismi arayıp bulacak ve onun maaşını gösterecektir.

 İlk örnekte sadece Niyazi isimli çalışanımızı arayıp bulma imkânımız vardı. Başka bir ismi bulmamız gerektiğinde ise formül içerisindeki Niyazi ifadesini değiştirmemiz gerekirdi fakat şimdi hücre belirttiğimiz için hücre içine ne isim yazarsak onu gösterecektir.

http://duzeybil.com.tr/duseyara-islevi-ile-excelde-arama_63.html